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Make a Fast, Easy Flying Logo
With LogoMotion it is so easy to produce a flying logo.
Make one for your company and get a Promotion!

Here’s an easy way to make
your first animated flying
logo. All your friends will
think it took you hours.

1. Create 3D Text
Create some text by choos-
ing the Text Tool on the
Toolbar (button whose icon
looks like a “T”) and clicking
on the Camera View
Window. In the dialog, type
in your name, choose a font,
select a bevel, and click
“OK.” Just like that, your
name will appear in 3D! 

Use the “Move” tool from
the Tool Palette to center
your newly created 3D text
in the Camera Window.

2. Apply a Surface
In the Surfaces Panel, select a
surface that you like and
simply drag it from the bin
and drop it onto your text.
To see the surface, select the
Rendering panel and choose
Fast from the choice of shad-
ing modes on the “Quality”
pop-up.

3. Add a Background
Here’s where using
LogoMotion gets really fun.
Go into the StageHands
Panel and click on the
Backdrops button. You’ll
notice the preview window
on the panel shows the back-
ground currently selected in
the bin. Find an image that
you like and – that’s right! –
just drag it into your scene. 

4. Now For a Prop
While in the StageHands
Panel, click on the Props but-

ton.  Once again use the pre-
view window and the bin on
the panel to find a cool prop
that you like. When you find
one, drag it into your scene.
To see a bounding box pre-
view of your animation,
choose Preview from the
Animate menu.

5. Make it Fly!
Click on the Camera button
in the StageHands Panel.
Just drag the desired camera
into your scene and *Pow!*
Your text is animated.
Choose Preveiw from the
Animate menu again. Pretty
cool, eh?

6. Make a Movie
Choose “Make Movie” from
the File menu. When the
“Render Setup” dialog box
appears, click on “Render.”
Give the movie a name and
save it on the desktop.
LogoMotion will take a few
minutes to render your
movie, so take a short break.
Once it’s finished, you can
view the movie by double-
clicking on its file icon on
the desktop.

7. Amaze Your Friends and Co-
Workers!
Once your movie is finished
rendering, it is ready for use
in any application that
accepts moviessuch as Adobe
Premiere or Macromedia
Director. To simply watch
your movie, double-click on
its icon on the desktop. A
standard movie player will
automatically run and play
the movie.

StageHands help speed up the process of producing animations.
You can quickly select from a collection of pre-made cameras,
lights, 3D objects, and backdrop images.

Impress all your friends and co-workers with your new 3D anima-
tion skills!!!

In the Text Dialog, type in any text, choose a font and a bevel,and
just like that a 3D object will be created.

          
    
          
    



How to Make Exploding Letters
Here’s something cool you can’t do in a 2D 
graphics program!

Here’s a quick tip for creating
the effect of your logo
exploding or flying together.

1. Create 3D Text
Create some text using the
Text Tool on the Toolbar
(button whose icon looks
like a “T”). Choose a font
and give it a bevel.

2.Break Into Characters
With the word selected,
choose “Break into
Characters” under the
Options menu. This process
separates the text object into
individual letters, where all
letters are “children” of the
first character (or in this case
the “F”). 

If you want, apply a new
surface to each of the letters
using the Surface Panel
(Command-2 on Mac or
Control-2 on Windows) to
drag & drop a desired sur-
face.

3.Link Characters to an Invisible
Parent Object
Sometimes animators use an
invisible parent object when
animating several objects
that move in relation to each
other. With the invisible par-
ent, the objects can be
moved all at once without
destroying their individual
motion. In fact, most of the
StageHands produced by
MetaCreations have invisible
parent objects for this pur-
pose. 

4. Move the World Time Marker
and Animate
In LogoMotion, animations
are produced by moving the

World Time Marker (the gray
pointer with the red line
coming out of it on the
Animation Sequencer) to a
different point on the time
line.

Move the World Time
Marker to one second. Now,
move each letter to a differ-
ent spot in the world. A blue
line will be created between
the object’s eventmarks on
the Sequencer when you
move the object to a new
spot in the scene. 

To position the characters,
it helps to use both the Top
View and the Right View.
These views can be opened
under the Windows menu.

Choosing “Preview” from
the Animate menu will dis-
play a bounding box preview
of your animation in what-
ever view is selected.

5.Reverse the Animation
If you leave the animation as
is, your text will look like it’s
exploding. To make it look
like the letters are flying
together, simply drag each
letter’s far-left eventmark on
the Animation Sequencer to
the 2-second point. Then
move the other eventmark of
that same object to the zero-
second point. Instantly your
animation is reversed!

After moving the World Time Marker on the Animation Sequencer
ahead one second, move the positions of each item in the scene.

Example of characters flying together to form a word:

Create 3D text with the Text Tool.Break the text into characters and
link the letters to an invisible parent object.

          
    
          
    



Importing Complex Models
Disney spent millions of dollars producing the movie Toy Story.
Heck... someone should have told them about LogoMotion!

Not only does LogoMotion
supply its own modeling
tools, but it also allows you
to import models from other
3D programs!

This feature can be perfect
for situations when you need
a complex model, but don’t
have the time or ability to
create it yourself. 

This example shows how
to import a DXF model of a
little girl. Models saved in
the 3DMF file format may
also be imported into
LogoMotion.

1.Import a DXF file
Select Import Objects under
the File menu. Use the dialog
that comes up to find the
‘Little Girl.dxf’ file, found in
the DXF Importing Example
folder in the Tips & Tricks
folder on the LogoMotion
2.1 CD-ROM. Make sure the
File Type to Import is set to
“DXF” instead of “3DMF.”
After hitting Open, choose
“Best Guess” in the DXF
Options dialg and import the
model.

2.Reorder Object Hierarchy
Now relink the objects in the
Animation Sequencer into a
series of child/parent rela-
tionships. This will help later
on when you animate the lit-
tle girl.

Child objects (items lower

on the hierarchy) move in
relation with their parent.
Thus, when linked properly,
the girl’s left thumb will
move with the left hand, the
left hand with the left arm,
the left arm with her upper
torso, and so on. 

Check out the sample
LogoMotion file “Little Girl
(LM file)” in the DXF
Importing Example file of
the Tips & Techniques folder
on the LogoMotion 2.1
Deluxe CD.

3. Apply Surfaces to Objects
By default, all DXF models
brought into LogoMotion
will be assigned a default
chrome surface. Unless
you’re making another
sequel to the Terminator
movies, you probably will
want to apply different sur-
faces that are more natural
for her. Use the Surface Panel
(Command-2 on Mac,
Control-2 on Windows) to
create these surfaces and
then drag & drop them onto
the objects in your scene.

Bring DXF or 3DMF Models  into LogoMotion by selecting Import
Objects under the File menu. Once the model is imported, use the
Animation Sequencer to reorder the linking of each objec t.

With the Surface Panel,apply new surfaces to each object.

You’re now set to create a whole animation with her as your star!

          
    
          
    



Sophisticated Flying Logo, Part I
Hey, why should the major studios have all the fun? It’s
easy to create a slick flying logo with LogoMotion 2.0!

After breaking text into characters, re-link the individual letters in
the Animation Sequencer. Make the  letters fall on a curved path by
entering numerical values into the Object Information Panel Mode.

Create more text with the Text Tool,then link all the objects to an
invisible parent object .

This example shows how to
create a variation of a famil-
iar animation: the Universal
Pictures logo seen at the
beginning of many movies.

1. Create 3D Text
First create some 3D text by
double-clicking on the Text
Tool in LogoMotion (button
on the Toolbar whose icon
looks like a “T”). In the Text
Dialog box, type in “UNI-
VERSE,” select the font
Times, and add a convex
bevel.

After LogoMotion gener-
ates the 3D text, use the
Surface Panel Mode (Choose
“Surfaces” from the
Windows menu) to switch
the text’s surface from the
default chrome to a gold sur-
face. Then elongate the verti-
cal dimensions of
“UNIVERSE” by changing
the numeric value on the Y
dimension from 1.0 to 1.5 in
the Object Information Panel
Mode. 

2.Tweak the Appearance of 
the Text
The next goal is to make the
letters fall on a curved path
instead of the default
straight line. 

Select “Break Into
Characters” under the
Options menu, which sepa-
rates the letters in the text
string into individual
objects. In the Animation
Sequencer, re-link the indi-
vidual letters by dragging the
name of one letter onto the
name of another letter. This
action makes each letter the
“child” of the letter before it
in the text string (see the

LogoMotion manual for
more information on creat-
ing hierarchies). Do this for
the letters “N” through to
the final “E.”

Finally,  set the child let-
ters’ positions to a curved
path by changing the Y-rota-
tion in the Object Panel
from 0 to 11 for each of
those letters. To see the effect
of the curved text, use the
Rotate tool to view the text
from a different angle (Just
be sure to choose ‘Undo’
from the Edit menu to
restore the original orienta-
tion!)

3. Add More Text and an
Invisible Parent Object
As in Step 1, add the words
“BIG” and “PICTURES” with
the Text Tool and position
them relative to the word
“UNIVERSE.” It is often
effective to join several
objects to an invisible parent
object, so a group of objects
can be moved relative to
each other without losing
any animation information. 

To do this, place an
extrude object into the
scene. Then make the cube
invisible by clicking the
“Visible” button in the
Object Information Panel to
“off.” To complete the pro-
cess, link the text objects in
the Animation Sequencer to
this invisible cube.

[Check out the next section to
learn how to finish creating this
flying logo. See how to add
complex DXFmodels and then
create the final animation!]

          
    
          
    



[Continued from Part I]

4.Bring in DXF Model of the
Earth
To prevent having a crowded
workspace, open a new scene
to serve as a work environ-
ment for producing a model
of the Earth. 

In short, the Earth model
can be created by combining
a lathe object (a sphere icon
on the Toolbar) and a DXF
import (DXF is a 3D file for-
mat, similar to what TIFF is
for 2D images). This DXF
was created with an Adobe
Photoshop plug-in called
CyberMesh that transforms
2D grayscale images into 3D
models. [Note: CyberMesh
can be ordered through
Knoll Software (415) 453-
2471]

Import the DXF Earth
model by choosing
Import>Objects from the File
menu. Set the File Type to
Import to DXF, and open
open the ‘Earth.dxf’ file
located in the Tips &
Techniques folder of the
LogoMoiton CD-ROM.
Accept the default settings
and click OK to import the
model.

5. Place Down a Sphere
To make the bodies of water,
place a sphere into the scene.
Then with the Uniform Scale
tool, enlarge the sphere to fit
just inside the DXF model of
the world. Once positioned,
link the two objects in the
Animation Sequencer.

For the final touch, create
two new surfaces in the
Surface Panel by choosing
New Surface from the
Options menu. Make one a
highly reflective variation of
the “Flat Blue” surface, and

apply it to the sphere to
resemble water. The second
should be a highly reflective
variation of the “Flat Green”
surface for the land masses.

6. Copy and Paste the Earth and
Animate
Next copy (Command-C,
Mac, Control-C, Windows)
the Earth from this work
scene and paste it
(Command-V, Mac, Control-
V, Windows) into the origi-
nal scene. With the help of
the Movement Tools, posi-
tion the Earth behind the
text.

Then create a simple ani-
mation of the Earth spinning
around. This spinning
motion can be produced by
moving the World Time
Marker on the Animation
Sequencer forward to a new
time and rotating the Earth
parent object an additional
90 degrees on the Z axis in
the Object Information
Panel. Repeat this four times
for a full rotation.

7. Add Environment and
Custom Backdrop 
As a final touch, add a back-
drop image of “Stars” from
the StageHands Panel. You’re
now ready to render the ani-
mation!

Sophisticated Flying Logo, Part II
Luckily, LogoMotion doesn’t require a license to fly. You can cre-
ate logos that zip through space right after opening the box!

Import a DXF model of the Earth. Place a sphere in the center of this
Earth object to ser ve as the Earth’s oceans.

Copy and paste the Earth behind the text. Then use the Animation
Sequencer to make the Earth spin.


